Finally bringing Prostar home to fix....
04-14-2018, (Subject: Finally bringing Prostar home to fix.... ) 
Post: #19
RE: Finally bringing Prostar home to fix....
Solved!

That's it folks, when the mechanic was diagnosing my blown transmission, they took off all ground and cleaned them but didn't spray anything on them so now I'm going to re clean them all and spray some battery post protection on them.

Trucks back to running like a champ! Thanks everyone for the help!


User's Signature: I'm no mechanic, I'm just a guy that breaks down enough to know a bit.
replyreply
 Thanks given by: Hammerhead , Rawze
04-14-2018, (Subject: Finally bringing Prostar home to fix.... ) 
Post: #20
RE: Finally bringing Prostar home to fix....
I put Fluid Film on my connections. It seems to work good. Prevents corrosion and seems to find its way into nooks and crannies.


User's Signature: The fastest way to learn is to make a mistake. If it costs me $ I learn pretty quickly. It's cheaper to learn from someone else's mistakes.
replyreply
 Thanks given by: Rawze , Brock
04-14-2018, (Subject: Finally bringing Prostar home to fix.... ) 
Post: #21
RE: Finally bringing Prostar home to fix....
   

Went to town today, every ground or 12v I could find! Never dealing with this crap again!


User's Signature: I'm no mechanic, I'm just a guy that breaks down enough to know a bit.
replyreply
 Thanks given by: BobsYourUncle , Hammerhead , Rawze , scottydogtruck
04-15-2018, (Subject: Finally bringing Prostar home to fix.... ) 
Post: #22
RE: Finally bringing Prostar home to fix....
I use this stuff on all exposed connections and in the back of all my plugs...
http://a.co/4kbqpBH


User's Signature: ->: What I post is just my own thoughts and Opinions! --- I AM Full Of S__T!.
replyreply
 Thanks given by: Brock , Roysbigtoys
04-17-2018, (Subject: Finally bringing Prostar home to fix.... ) 
Post: #23
RE: Finally bringing Prostar home to fix....
Well crap! I may have spoke too soon. Today it didn't start, relay would click but not the starter. Dash said electrical fault and all my switch lights were coming on and off.

Got it started and drove for 2 hours flawlessly but I have active fault code 1117..... here we go again!


User's Signature: I'm no mechanic, I'm just a guy that breaks down enough to know a bit.
replyreply
04-18-2018, (Subject: Finally bringing Prostar home to fix.... ) 
Post: #24
RE: Finally bringing Prostar home to fix....
I am sure you checked and know ...
But we had one do that and it was the Damm relay for the starter and the firewall .
Why have one relay when you can have two ....


User's Signature: The missing link
replyreply
 Thanks given by: Brock
04-18-2018, (Subject: Finally bringing Prostar home to fix.... ) 
Post: #25
RE: Finally bringing Prostar home to fix....
I swapped out all ignition relays with new


User's Signature: I'm no mechanic, I'm just a guy that breaks down enough to know a bit.
replyreply
Yesterday, (Subject: Finally bringing Prostar home to fix.... ) 
Post: #26
RE: Finally bringing Prostar home to fix....
Ok so I've got it cased..... again....

I had that 1117 code, I also had the truck acting up randomly while driving. It would kick my autoshift into nuteral and all sorts of alarms and light a would come on, abs, engine light, electrical fault warning, etc etc.

Found the ground on the block needed cleaning up. I cleaned the one ground the other day and just sealed the rest as they didn't look all that bad....... WRONG! so looks like I needed to redo them all right!

Truck runs mint now! The fault 1117 is gone. The truck still has a issue with not starting randomly but that is going to be easy to find and fix.

Boy has this been a headache and a half, sure glad I finally got it figured out.


User's Signature: I'm no mechanic, I'm just a guy that breaks down enough to know a bit.
replyreply
 Thanks given by: Waterloo
Yesterday, (Subject: Finally bringing Prostar home to fix.... ) 
Post: #27
RE: Finally bringing Prostar home to fix....
The electrical on these trucks is a F'n NIGHTMARE! Going to be my next project after Rawze and I get this thing back together, grounds and electrical, again. This is a continual problem, especially for us Northern boys.
replyreply
 Thanks given by: Brock





  
  
Theme by MyBB Addict
Contact Us | Rawze.com | Return to Top | Return to Content | Lite (Archive) Mode | RSS Syndication