Pre-emission ISX turbo issue
05-12-2019, (Subject: Pre-emission ISX turbo issue ) 
Post: #1
Pre-emission ISX turbo issue
I have a 2003 W900 with a 2002 ISX rated at 550hp, about 3 years ago I blew up the turbo and had Cummins put a new one on,after I got the truck back and took off down the road i got a check engine light and it derated. I took it to the next Cummins shop and they told me it was the intake pressure sensor ..that wasn't it...have replaced Barometric pressure sensor replaced vacuum line to turbo...still did the same thing... engine code says it was Turbo speed sensor...how does this happen when there is no such sensor on a waste gate turbo?... I have since backed the waste gate off by 6 turns,no check engine and no derate,but lost power and fuel mileage...
replyreply
05-13-2019, (Subject: Pre-emission ISX turbo issue ) 
Post: #2
RE: Pre-emission ISX turbo issue
(05-12-2019 )Dakota Wrote:  I have a 2003 W900 with a 2002 ISX rated at 550hp, about ""3 YEARS"" ago I blew up the turbo and had Cummins put a new one on,after I got the truck back and took off down the road i got a check engine light and it derated

Is this a recent problem or are you just checking if a 3 year old remedy has a better fix?

I don't know the cm570's terribly great, but, it sounds like your turbo was over speeding and you opened the waste gate to dump boost. What is the peak boost pressure you're reaching? Have you tried to close the waste gate a few turns to see if pressure rises but stays with in specs?
replyreply
05-13-2019, (Subject: Pre-emission ISX turbo issue ) 
Post: #3
RE: Pre-emission ISX turbo issue
Been fighting it for 3 years...it boosts about 30-32 pounds...when turning waste gate nut I would go 1 turn and check how it acted..it calmed down at 6 turns. Before it was adjusted it was boosting about 35-38 pounds
replyreply
05-13-2019, (Subject: Pre-emission ISX turbo issue ) 
Post: #4
RE: Pre-emission ISX turbo issue
35-38lbs is right for 550HP thats what my truck runs around with a cm871 500/1850
replyreply
05-14-2019, (Subject: Pre-emission ISX turbo issue ) 
Post: #5
RE: Pre-emission ISX turbo issue
Do you have Cummins Insite? Do you know what the actual sensors are reading? Maybe the sensor wiring is bad. Is your code intermittent or every time you do something specific?
replyreply
05-14-2019, (Subject: Pre-emission ISX turbo issue ) 
Post: #6
RE: Pre-emission ISX turbo issue
The cm570 does not have a turbo speed sensor. It has tables to estimate turbo speed based on boost pressure and engine speed. It would be throwing fault code 595 I believe. Is it a small HP engine that's been uprated to 550 by any chance?
replyreply
05-14-2019, (Subject: Pre-emission ISX turbo issue ) 
Post: #7
RE: Pre-emission ISX turbo issue
No on the insite... it's a factory it's an actual 550..its not a small engine that's been upgraded..
replyreply
05-15-2019, (Subject: Pre-emission ISX turbo issue ) 
Post: #8
RE: Pre-emission ISX turbo issue
Your problem is probably just wastegate adjustment then.
replyreply
05-15-2019, (Subject: Pre-emission ISX turbo issue ) 
Post: #9
RE: Pre-emission ISX turbo issue
It was installed at factory spec and adjusted to open earlier..At factory spec is when it acts up
replyreply





  
  
Theme by MyBB Addict
Contact Us | Rawze.com | Return to Top | Return to Content | Lite (Archive) Mode | RSS Syndication