low coolant alarm won't stop
06-05-2019, (Subject: low coolant alarm won't stop ) 
Post: #10
RE: low coolant alarm won't stop
Thanks guys!

I did replace the pigtail. Will check the tank magnet and replace wires as far back as possible.

BTW, Low air pressure transducers are to the left of the steering column near the floor.


User's Signature: 2010 386 Pete CM871, 13 spd. 3.55
replyreply
06-05-2019, (Subject: low coolant alarm won't stop ) 
Post: #11
RE: low coolant alarm won't stop
(06-05-2019 )in2trux Wrote:  Thanks guys!

I did replace the pigtail. Will check the tank magnet and replace wires as far back as possible.

BTW, Low air pressure transducers are to the left of the steering column near the floor.

As others have said replace the tank or use Unilevers fix. I had the same problem with my 579 Pete, my buddy and cousin had same issue with 384 and 386 Pete. Bought sensors and chased wires for days. It was the damn tank every time.
replyreply
 Thanks given by: in2trux
06-24-2019, (Subject: low coolant alarm won't stop ) 
Post: #12
RE: low coolant alarm won't stop
(06-05-2019 )MCRENT Wrote:  
(06-05-2019 )in2trux Wrote:  Thanks guys!

I did replace the pigtail. Will check the tank magnet and replace wires as far back as possible.

BTW, Low air pressure transducers are to the left of the steering column near the floor.

As others have said replace the tank or use Unilevers fix. I had the same problem with my 579 Pete, my buddy and cousin had same issue with 384 and 386 Pete. Bought sensors and chased wires for days. It was the damn tank every time.

Thanks Mcrent!
I replaced the tank and the alarm went away!
$325 for a new tank, includes the $200 sensor.
Sometimes remove and replace works.


User's Signature: 2010 386 Pete CM871, 13 spd. 3.55
replyreply





  
  
Theme by MyBB Addict
Contact Us | Rawze.com | Return to Top | Return to Content | Lite (Archive) Mode | RSS Syndication