ISB in limp mode/No Codes
06-26-2019, (Subject: ISB in limp mode/No Codes ) 
Post: #1
ISB in limp mode/No Codes
Have a 2011 Ford F650 Cummins ISB that came in with DEF tank issues which turned into multiple codes. After repairing tank(changed tank module), cleared codes and did a regen. Had a NOX sensor problem. Replaced and there are no codes at all on engine. Body controller has a cruise switch code and the Wabco brakes have two codes, but nothing that I think would put it in limp mode(10 MPH). I went in and reset dpf filter. It ran down the road once and now it stays in limp mode. Do I need to get the ECM reflashed? There is no telling how long they have operated this truck with def tank problems...I'm sure till it would not run period. I'm stumped.
replyreply
06-26-2019, (Subject: ISB in limp mode/No Codes ) 
Post: #2
RE: ISB in limp mode/No Codes
(06-26-2019 )mayhem1 Wrote:  ...
I went in and reset dpf filter.
...

you should never do this unless you have pulled the DOC and DPF and had them professionally baked, de-ashed, and flow-tested. - Doing so throws the entire system off and makes it worse.

your next move it to remove them and actually have it done... THEN do a proper reset.

Also have the SCR can flow tested or inspected for restriction,. and do an thorough EGR tune-up, fix all problems that may be making it produce too much soot, fix any problems that lower fuel mileage, etc. + change oil at short intervals to de-soot the engine.


-- Sounds like you have one seriously neglected truck on your hands there.


User's Signature: ->: What I post is just my own thoughts and Opinions! --- I AM Full Of S__T!.
replyreply
 Thanks given by: mayhem1





  
  
Theme by MyBB Addict
Contact Us | Rawze.com | Return to Top | Return to Content | Lite (Archive) Mode | RSS Syndication