Cm2350 Logging 2554 and 2764 codes
10-01-2020, (Subject: Cm2350 Logging 2554 and 2764 codes ) 
Post: #1
Cm2350 Logging 2554 and 2764 codes
2554 code as active and 2764 is inactive. Anyone has experienced this in the past and possibly found solution to it. Thanks in advance, Jacob
replyreply
10-01-2020, (Subject: Cm2350 Logging 2554 and 2764 codes ) 
Post: #2
RE: Cm2350 Logging 2554 and 2764 codes
(10-01-2020 )Kubasj05 Wrote:  2554 code as active and 2764 is inactive. Anyone has experienced this in the past and possibly found solution to it. Thanks in advance, Jacob

fault code 2554 = The exhaust gas pressure sensor is reading an erratic value.

fault code 2764 = High exhaust gas pressure has been detected by the exhaust gas pressure sensor.

==============

it is not a common error to see.

Could be ...

============================
(if truck had delete programming)...
* Bad programming and turbo is over-spooling/over-boosting, engine going into wrong engine modes and getting stuck there.

* Bad hardware mods where someone did not properly hollow out all the exhaust cans and now the exhaust is plugging up.

* Improper boost levels set and engine is over-boosting/turbo is over-spooling for one reason or another.

* Could be clogged cross-pipe for the sensor or a bad sensor.

* Could be wiring issue.

-- You mentioned you have a de-mandated truck here ...
http://rawze.com/forums/showthread.php?t...2#pid58722


I would start by making sure the program is good for it by pulling a copy of it out and e-mail it to me for a review of what someone has done to it. The average seen on the forum here is 90%+ odds the program is bad in some harmful way.


User's Signature: ->: What I post is just my own thoughts and Opinions! --- I AM Full Of S__T!.
replyreply
 Thanks given by: Kubasj05
10-01-2020, (Subject: Cm2350 Logging 2554 and 2764 codes ) 
Post: #3
RE: Cm2350 Logging 2554 and 2764 codes
(10-01-2020 )Rawze Wrote:  
(10-01-2020 )Kubasj05 Wrote:  2554 code as active and 2764 is inactive. Anyone has experienced this in the past and possibly found solution to it. Thanks in advance, Jacob

fault code 2554 = The exhaust gas pressure sensor is reading an erratic value.

fault code 2764 = High exhaust gas pressure has been detected by the exhaust gas pressure sensor.

==============

it is not a common error to see.

Could be ...

============================
(if truck had delete programming)...
* Bad programming and turbo is over-spooling/over-boosting, engine going into wrong engine modes and getting stuck there.

* Bad hardware mods where someone did not properly hollow out all the exhaust cans and now the exhaust is plugging up.

* Improper boost levels set and engine is over-boosting/turbo is over-spooling for one reason or another.

* Could be clogged cross-pipe for the sensor or a bad sensor.

* Could be wiring issue.

-- You mentioned you have a de-mandated truck here ...
http://rawze.com/forums/showthread.php?t...2#pid58722


I would start by making sure the program is good for it by pulling a copy of it out and e-mail it to me for a review of what someone has done to it. The average seen on the forum here is 90%+ odds the program is bad in some harmful way.
Thank you for heads up Rawze,
My truck is still mandated, running it in stock mode. I'm thinking about de-mandating it asap.
After clearing up the codes I decided to do parked regen just to see if it will complete it.
The result was: Failed due to VG being too low or below minimum and turbocharger too high (can't remember the exact reasoning, excuse my short memory) I will re run a regen tomorrow to get exact message it displayed.
I'm assuming the turbocharger was over spooling. I just wonder if this is turbo VG actuator going bad having turbo to overspool or is it a turbocharger and the actuator going bad all together.
On the side note, after failed regen ecu didn't throw any codes and the dpf cleaning process during regen looked good with Temps at around 1025-1040. Also DPF soot load guage indicated minimal soot load. No other codes associated with regen.
Any additional thoughts?
Thank you, Jacob
replyreply
10-01-2020, (Subject: Cm2350 Logging 2554 and 2764 codes ) 
Post: #4
RE: Cm2350 Logging 2554 and 2764 codes
(10-01-2020 )Kubasj05 Wrote:  ...
I'm assuming the turbocharger was over spooling. I just wonder if this is turbo VG actuator going bad having turbo to overspool or is it a turbocharger and the actuator going bad all together.
...

Could be a turbo issue but could also be CAC or other leaks causing boost loss and the turbo is tryign to make up for it. Could be plugged air filter, plugged exhaust, etc.

Your next move is to check the intake for leaks by pressurizing it. Also to remove the DOC/DPF and have them baked, de-ashed, and flow tested... and to inspect the decomp tube + SCR element for partial clogging, face-plugging while you there. Go thru the EGR corcuit and ensure there is good flow and that the sensors are not clogged up.

-- Also an EGR tune-up + IMAP sensor replacement, etc. if it has not been done.

Turbo replacement should be the very last thing you do or consioder, not the first... and if it has to come off, and there is 500k+ on the engine and egr cooler, remove the egr cooler while your at it and clean it out of all carbon and soot buildup while the turbo is off it.


User's Signature: ->: What I post is just my own thoughts and Opinions! --- I AM Full Of S__T!.
replyreply
10-01-2020, (Subject: Cm2350 Logging 2554 and 2764 codes ) 
Post: #5
RE: Cm2350 Logging 2554 and 2764 codes
From what I have noticed turbocharger and actuator are original, truck has 505k on. Looks like new egr cooler, new exhaust gas pressure sensor but egr related sensors look original.
I'll take a look at some stuff tomorrow and give an update.
Your input is much appreciated, also I felt like donating as it's all worth it at the end
replyreply
10-02-2020, (Subject: Cm2350 Logging 2554 and 2764 codes ) 
Post: #6
RE: Cm2350 Logging 2554 and 2764 codes
2554 and 2764 Resolved however, regens complete but with failed result.
After unsuccessful regens this morning decided to look closely at the sensors and 3 out of 4 (except Imap) been replaced recently including exhaust gas pressure sensor. Returned to Insite and noticed that every time now when I wanted to run a test involving regen, as soon as boost hit designated levels it would throw Cel and kick me out it. FYI, day earlier had no such issues, I'm thinking weird huh? This behavior led me to believe that I may have a wiring problem, guess what I have discovered lol!
Someone has already messed with Exhaust gas pressure sensor wiring (see picture) the white signal wire was cut off before the plug, it was substituted by yellow wire that was ran inside silver 1/4 in air line. I began to follow it and it took me all the way to the top ECM plug where it originated, so there was my aha moment. Initially I thought that this is going to be a mess but at the end it turned out to be issue relating to crappy contact by EGPS sensor prong and the plug. Cleaned both the plug and the 3 sensor prongs, applied some aluminum antisize lubricant, twisted the prongs ever so slightly also since I was there I cleaned up the supply line for EGPS which wasn't clogged, I've removed a little bit of soot from the manifold body where the sensor is located. Perform few tests and ran around the block and no code, so I think I may be alright with getting rid of codes 2554 & 2764 however as I mentioned earlier I still have failed regen with no codes due to turbo over spool is what it said in the messages after regen process has stopped (see additional pics)

My question to you professionals is:
Is 84,000 turbo rpm too high during a regen, it was the highest speed registered (see picture). Is there a possibility that turbo speed sensor is giving faulty readings back to ECM thus my regen fails?
I did VG test and it passed also, I followed a turbo speed readings (percentage) and it matched desired to actual. Truck completes regen as soot levels afterwards is in the range 5%

Looking for some opinions, thanks everyone
Sorry not enough space to include all of the pictures, I'll add them in next post.


Attached File(s)Thumbnail(s)
               
replyreply





  
  
Theme by MyBB Addict
Contact Us | Rawze.com | Return to Top | Return to Content | Lite (Archive) Mode | RSS Syndication