Cm2350 high commanded vgt
11-12-2020, (Subject: Cm2350 high commanded vgt ) 
Post: #1
Cm2350 high commanded vgt
Well I’ve exhausted searching the forum and google for a week now on this issue.
I have a 2015 389 with 500 1650/1850ST cm2350. Vgt is commanding around 80% closed at idle most of the time. After awhile it will go down into the 40s to eventually go up again. The turbo is randomly chuffing at idle, when commanded goes down it will stop, sometimes slightly doing it.
Fuel mileage is down 1.5 mpg. Acts like it’s stuck in scr warm up. Just throwing this out right now, I don’t want to drive the truck like this but have no choice. I have a boss that doesn’t like the newer trucks and has no interest in understanding them or implications for not fixing them immediately. I take care of the truck.
Anyways, I have done a full egr tune up, replaced egr differential sensor, exh back pressure sensor, both nox sensors, cleaned the imap(I’ll get a new one tomorrow if I can). New def doser, new dpf doser.
Doc and dpf are a year old. They were replaced because of face plugging in -50 weather in Canada. Regens seem to only be about once a week miraculously and is under 0.5 after regen.
CAC was replaced recently with a durashitter(not my choice) no boost leaks after soapy water test.

Looking for what I should check next. Was thinking of checking the egr orifice pressure sensor. I for got that one.

Thanks
replyreply
11-12-2020, (Subject: Cm2350 high commanded vgt ) 
Post: #2
RE: Cm2350 high commanded vgt
Did you read all of this?

http://rawze.com/forums/showthread.php?t...8#pid22458

Leaking egr circuit

Plugged egr cooler

Bad egr orifice pressure sensor like you mentioned


User's Signature: Warranty??? Yeah right, I am the warranty!!!
replyreply
11-12-2020, (Subject: Cm2350 high commanded vgt ) 
Post: #3
RE: Cm2350 high commanded vgt
If all the above checks out, I've had intermittently failing turbo speed sensors cause chuffing, but you'd have to datalog it with InSite at a high sample rate for a while to catch it. The EGR is the most likely cause though.
replyreply
11-12-2020, (Subject: Cm2350 high commanded vgt ) 
Post: #4
RE: Cm2350 high commanded vgt
(11-12-2020 )Carhauler Wrote:  Well I’ve exhausted searching the forum and google for a week now on this issue.
...
CAC was replaced recently with a durashitter(not my choice)
...

This could also be a heavy contributor of what is wrong. those durasuck coolers are very restrictive and cost not only fuel mileage but over-works the turbo to overcome their terrible flow issues. They have quite a number of fewer passageways and do not cool the air nearly as well compared to the OEM CAC coolers to accommodate their bulls$it gasket system inside the CAC to prevent leaks and this is a problem for many trucks and that brand of garbage. Here is some older posts on this...

http://rawze.com/forums/showthread.php?t...41#pid3441

durasuck causing someone performance issues: http://rawze.com/forums/showthread.php?t...42#pid3442

and: http://rawze.com/forums/showthread.php?t...74#pid8274

same thing with those garbage aftermarket egr coolers ... they will actually kill an engine. ref: http://rawze.com/forums/showthread.php?t...33#pid2233


as far as your original problems, the egr cooler is the most likely culprit of all the egr sensors and piping have been changed out. That turbo chuffing is going to kill that turbo. Every time it does this, the turbine blades are vioilently reversing due to over-pressure built up in the CAC and it relieving it backwards thru the turbo. This also causes the engine to fight itself all the time against this extra uneeded pressure and drops fuel mileage like a rock.

You did not mention that you replaced the exhaust gas pressure sensor (the one on the thermostat housing).. that one can cause issues like this too.. and the passageways/circuit for it likes to clog up too. When the sensor is out, spray some brake cleaner into the hole and crank the truck to see if it comes blasting back up out of the hole while the sensor is off it to ensure the circuit is clear. This is a common issue.


User's Signature: ->: What I post is just my own thoughts and Opinions! --- I AM Full Of S__T!.
replyreply
 Thanks given by: redbeard
11-12-2020, (Subject: Cm2350 high commanded vgt ) 
Post: #5
RE: Cm2350 high commanded vgt
I replaced the exhaust back pressure sensor, cleaned the tube and block about a month ago. No change at all


I tried for the paccar cac. But all he saw was$$$$ in his pocket.
replyreply
11-13-2020, (Subject: Cm2350 high commanded vgt ) 
Post: #6
RE: Cm2350 high commanded vgt
Exhaust pressure reads atmospheric with engine off.
Egr orifice is -2 inhg at engine off.
Maybe the culprit?


Attached File(s)Thumbnail(s)
   
replyreply
11-13-2020, (Subject: Cm2350 high commanded vgt ) 
Post: #7
RE: Cm2350 high commanded vgt
(11-13-2020 )Carhauler Wrote:  Exhaust pressure reads atmospheric with engine off.
Egr orifice is -2 inhg at engine off.
Maybe the culprit?

The egr pressure sensor and exhaust pressure sensor are the same part#. Maybe swap them and see if the numbers change?.


Also you want to ensure that some moron did not "up the horsepower" in the engine and that the program matches exactly the engine and truck. Make sure the calibration phase in Insite shows the same as what the engine calls for on the data-plate and on Quickserv. Sometimes shops will change the HP of the engine and it will cause issues like this later on when because the DPF or other truck components external to the engine (or internal engine components sometimes too) do not match the required program that the ecm needs.

You also want to ensure that the software in the ecm is completely up to date (within 6 months old). Older ecm software from a couple years ago or more has been known to cause issues like your getting if everything is not perfect on the engine.

-- If I owned it, the entire egr circuitry + egr cooler would have come off it ... 100% of all of it + the intake manifold and had been cleaned out squeaky clean ... piping, cooler, egr valve, all cross-channels and feed tubes, and all sensors replaced at once. Would have pulled the DOC and DPF and had them sent off to bake them, de-ash them + flow test them. Would inspect the Decomp tube for any restrictions, Cleaned out the DEF system and DEF filter, cleaned the DOser and DEF injector tips, and had yanked that dammed CAC off in a hurry and gotten an OEM cac to put back on it + pressure tested the entire engine (not just the CAC) when it all went back on to ensure there were no leaks to any of it. AND i would have updated the software in the ecm to latest version because out of date software has been known to cause this issue too. -- How much you want to bet that I could have found the problem?

- You not owning the truck should show you that you can't skimp on s$it or half-arsse things in this trucking industry, because it will eat all your profits up in a hurry with plaguing problems, extra down-time, etc. and cost you expensive components like $5,000 worth of failed turbochargers all because some idiot tried to save a few pennies on aftermarket garbage.


User's Signature: ->: What I post is just my own thoughts and Opinions! --- I AM Full Of S__T!.
replyreply
11-13-2020, (Subject: Cm2350 high commanded vgt ) 
Post: #8
RE: Cm2350 high commanded vgt
So I’ve basically done all that except pull the cooler....
ecm was just updated by a Peterbilt. I watched the tech do it.
It was a matching file.
I only work on it to try and keep me moving. If not they would butcher it.
They like to just swap parts and not figure out what causes problems.
replyreply
11-14-2020, (Subject: Cm2350 high commanded vgt ) 
Post: #9
RE: Cm2350 high commanded vgt
Ok, so I have logged the vgt and egr and various other parameters while driving, seems driving is fairly normal. Only idle is where is commands 80-90%. When egr starts to open it commands the highest and you can here the turbo whistle less from the drop in exhaust pressure.
There are no leaks in the egr system and the sensors and valve appear ok.

Did a regen last night. Dpf differential pressure ended up at .03 at idle. Didn’t take long either.

It has been pretty cold. 20-30 at night and 30-40 during the day.
When the Scr stays warm it seems to back off the vgt. Then it cools down and the cycle starts over.
Any ideas?
replyreply





  
  
Theme by MyBB Addict
Contact Us | Rawze.com | Return to Top | Return to Content | Lite (Archive) Mode | RSS Syndication