CM 870 idle issue after start up
03-25-2021, (Subject: CM 870 idle issue after start up ) 
Post: #1
CM 870 idle issue after start up
Hi all. Looking for some help before I'm forced to head to the stealership.

Upon startup I've had a slight idle stutter/hesitation? Used to go away if I bumped up the cruise idle. Lately seems to keep doing it for a while then evens out. Getting worse in frequency. Doesn't do it after sitting overnight just if I shut off truck for a while then happens when I start ot up again. No check engine warning lights.

Last year I had the fuel shutoff solonoid replaced from advise online which fixed some bad issues where idle was extremely bad low fuel pressure warning lights etc. Non driveable. At the time dealer told me my tanks needed to come off the IFSM was clogged and it was going to be thousands of dollars. Turned out it was a $100 solonoid.

Were they correct though that I may have gunk in the fuel system thst got through filters? Maybe the actuators? I did have the 280/350? regulators cleaned at the time....

Anyways maybe related a couple times a week I get a check engine light while driving goes away after 5 min leaving no faults on the dash display.

My local shop has let their Cummins insite expire so I'm kind of screwed where I am for now till light stays on and I find a good shop in Niagara, Ontario Canada. I don't wan to go back to that dealer again.

If this sounds similar to your experience please help. Thanks!
replyreply
03-25-2021, (Subject: CM 870 idle issue after start up ) 
Post: #2
RE: CM 870 idle issue after start up
air getting in the fuel system?


User's Signature: ->: What I post is just my own thoughts and Opinions! --- I AM Full Of S__T!.
replyreply
 Thanks given by: Craag
03-25-2021, (Subject: CM 870 idle issue after start up ) 
Post: #3
RE: CM 870 idle issue after start up
Part 1 https://youtu.be/MWiSwgcwIoc

Part 2 https://youtu.be/_WeiDC6S8Lw

This is your fuel system in depth. Watch and learn. Then start to pull things apart and check them yourself. Don't rely on a stealershit to do anything but lighten the load in your wallet.

Rawze also has a video on how to check your fueling/metering actuators. I can't find the video right now but you should probably have a look at them. These could be the cause of some of your problems. I Think its in here somewhere https://www.youtube.com/channel/UCZ08qn4...LSQ/videos
replyreply
03-26-2021, (Subject: CM 870 idle issue after start up ) 
Post: #4
RE: CM 870 idle issue after start up
(03-25-2021 )Rawze Wrote:  air getting in the fuel system?

I had thought of that too it's distressing when you show or tell a certified diesel tech that they don't automatically think it too as I'm by far less qualified. My only question I had to that is why it's fine first thing in the AM after sitting the night?

After I start the truck it idles then it kind of revs itself up a tiny amount 10 or so seconds later as if I touched accelerator them settled in its normal idle. That is normal for past seven years. Now when it goes to do that little rev it's like it gets stuck in it repetitively attempting it. Almost like a little whine sound like a turbo spinning when it happens too. I almost wonder if it's ecm related?
replyreply
03-26-2021, (Subject: CM 870 idle issue after start up ) 
Post: #5
RE: CM 870 idle issue after start up
(03-25-2021 )Chamberpains Wrote:  Part 1 https://youtu.be/MWiSwgcwIoc

Part 2 https://youtu.be/_WeiDC6S8Lw

This is your fuel system in depth. Watch and learn. Then start to pull things apart and check them yourself. Don't rely on a stealershit to do anything but lighten the load in your wallet.

Rawze also has a video on how to check your fueling/metering actuators. I can't find the video right now but you should probably have a look at them. These could be the cause of some of your problems. I Think its in here somewhere https://www.youtube.com/channel/UCZ08qn4...LSQ/videos

I had seen Rawzes thread on the actuators when I first googled the issue. I'll have to check out the video. A comment mentioned switching the front and rear ones to see if it makes a difference.

I guess a good place to start. Thanks!
replyreply
 Thanks given by: Zapah
03-26-2021, (Subject: CM 870 idle issue after start up ) 
Post: #6
RE: CM 870 idle issue after start up
(03-26-2021 )Craag Wrote:  
(03-25-2021 )Rawze Wrote:  air getting in the fuel system?

I had thought of that too it's distressing when you show or tell a certified diesel tech that they don't automatically think it too as I'm by far less qualified. My only question I had to that is why it's fine first thing in the AM after sitting the night?

After I start the truck it idles then it kind of revs itself up a tiny amount 10 or so seconds later as if I touched accelerator them settled in its normal idle. That is normal for past seven years. Now when it goes to do that little rev it's like it gets stuck in it repetitively attempting it. Almost like a little whine sound like a turbo spinning when it happens too. I almost wonder if it's ecm related?

run the overhead valve adjustment on it nad then do an injector leak test next. Make sure it passes.


https://odysee.com/@rawze:d/isx-injector...awze-2-3:b

https://odysee.com/@rawze:d/isx-injector...awze-3-3:7


User's Signature: ->: What I post is just my own thoughts and Opinions! --- I AM Full Of S__T!.
replyreply
 Thanks given by: Zapah , Craag
03-26-2021, (Subject: CM 870 idle issue after start up ) 
Post: #7
RE: CM 870 idle issue after start up
I was just watching this today! Great thanks! You and others on here go way above and beyond to help out.

Do you think this could be a turbo actuator issue also? What's got me thinking this is that after a pull, there is a short hill on the way to the customer and loaded we pull 120,000 lbs gross, and that sometimes after I get off it and cruise and if the rpm falls too low like 1250-1300 the cel comes on briefly then goes away 5 or so min later. Then later after shutting down and restarting that's when I get the idle issue as opposed to when it sits overnight and doesn't do it. Makes me wonder if the actuator can get stuck or if that's even a thing with these? I try to keep boost at around 30 but once in a while I catch it creeping up to 35 before I back off a bit. RPM is weird on my route in Canada we are 80 km/hr which is 1200 rpm in top gear way too low, drop down to 14th and it feels too high. 90 (55) feels better I believe its around 1350-1400 then the company I lease for is after me for speeding.

I really need insite and a way to put it to use. I see from a different post I need Insite version 7.6.2 Service pack 5 with a inline 5 or 6 adapter to plug in....and a laptop which is a problem at the moment. Will this give me access to read codes and service procedures or is there further licensing to buy? I checked this out a few months back and I couldn't run anything at the time on my old computer and ended up getting a next to useless app on my phone.
replyreply
03-26-2021, (Subject: CM 870 idle issue after start up ) 
Post: #8
RE: CM 870 idle issue after start up
if it has a poorly made delete program in it, it could cause the surge, but not usually rough idle. Is it still got factory programming and egr active?.. or is it deleted?. and if its deleted, by whom?


User's Signature: ->: What I post is just my own thoughts and Opinions! --- I AM Full Of S__T!.
replyreply
03-26-2021, (Subject: CM 870 idle issue after start up ) 
Post: #9
RE: CM 870 idle issue after start up
(03-26-2021 )Craag Wrote:  I really need insite and a way to put it to use. I see from a different post I need Insite version 7.6.2 Service pack 5 with a inline 5 or 6 adapter to plug in....and a laptop which is a problem at the moment. Will this give me access to read codes and service procedures or is there further licensing to buy? I checked this out a few months back and I couldn't run anything at the time on my old computer and ended up getting a next to useless app on my phone.

Go to fleabay and buy an inline adapter that comes with insite 7.6.2 that's all you'll need to read codes and run tests. It's usually around $300.00


User's Signature: Warranty??? Yeah right, I am the warranty!!!
replyreply
 Thanks given by: Rawze , Craag





  
  
Theme by MyBB Addict
Contact Us | Rawze.com | Return to Top | Return to Content | Lite (Archive) Mode | RSS Syndication