2009 ISX600...engine light-stop engine light
09-13-2021, (Subject: 2009 ISX600...engine light-stop engine light ) 
Post: #1
2009 ISX600...engine light-stop engine light
Hey Guys, Thought I'd pick some brains about my Bluebird coach, it's a 2009 that originally came with a Cat C13, That I swapped out for a new 2009 ISX600 right off the top when it was new. It's a straight pipe set up and has worked flawlessly for the last 10 years with just regular maintainance (oil and all filters).

The problem im having now, especially after it's been sitting is the Dash will randomly light up with "check engine" "stop engine" "check trans" "atc" all at the same time, with each light flashing randomly........ And While the lights are flashing, I have no response from the throttle pedal at all, but the engine doesnt shut off, just goes unresponsive and the coach will roll to a stop..... It stops flashing, then I can press the gas again, but then the warnings cycle on and off, with lose of power every time the flashing begins.

If I turn off the main power from the batteries and reset it, once I start back it's usually fine, however once in a while, it'll randomly act up again even after the first reset, and the second rest usually fixes for the rest of my trip, or until I park the bus again and shut it down.

Any ideas what could be causing this?
replyreply
09-13-2021, (Subject: 2009 ISX600...engine light-stop engine light ) 
Post: #2
RE: 2009 ISX600...engine light-stop engine light
I would guess that it's losing a connection somewhere. Could be anywhere from the batteries to transmission control unit (wherever it's at?). Check fuses for light corrosion on the blades, and as for the plug connections, I've had pretty good results lightly spraying with CRC electrical cleaner and blow drying, with a light spray of Amsoil metal protector.

Something that sits a lot seems to develop more gremlins it seems.
replyreply
09-13-2021, (Subject: 2009 ISX600...engine light-stop engine light ) 
Post: #3
RE: 2009 ISX600...engine light-stop engine light
(09-13-2021 )DavidG Wrote:  ... swapped out for a new 2009 ISX600
...
It's a straight pipe set up
...


the next big concern is that it is obviously deleted ... you can be assured that the programming in the ecm is most likely bad (more than 90% odds are against you), and severely harmful to the engine. -- copy the program out of the ecm and e-mail it to me for review .. does not matter "how well you think it is running"... this should be your top priority if you give a damn about the engine at all.


User's Signature: ->: What I post is just my own thoughts and Opinions! --- I AM Full Of S__T!.
replyreply
09-14-2021, (Subject: 2009 ISX600...engine light-stop engine light ) 
Post: #4
RE: 2009 ISX600...engine light-stop engine light
(09-13-2021 )Nostalgic Wrote:  I would guess that it's losing a connection somewhere. Could be anywhere from the batteries to transmission control unit (wherever it's at?). Check fuses for light corrosion on the blades, and as for the plug connections, I've had pretty good results lightly spraying with CRC electrical cleaner and blow drying, with a light spray of Amsoil metal protector.

Something that sits a lot seems to develop more gremlins it seems.


Yea im concerned that since this was an engine swap, and it went from CAT to Cummins, theres alot of wire splicing back there, and I dont know if I'll ever figure it out...... but wanted to hear opinions incase it's ECU problem that stands out....
replyreply
09-14-2021, (Subject: 2009 ISX600...engine light-stop engine light ) 
Post: #5
RE: 2009 ISX600...engine light-stop engine light
(09-13-2021 )Rawze Wrote:  
(09-13-2021 )DavidG Wrote:  ... swapped out for a new 2009 ISX600
...
It's a straight pipe set up
...


the next big concern is that it is obviously deleted ... you can be assured that the programming in the ecm is most likely bad (more than 90% odds are against you), and severely harmful to the engine. -- copy the program out of the ecm and e-mail it to me for review .. does not matter "how well you think it is running"... this should be your top priority if you give a damn about the engine at all.

Yes, the entire system was removed before it was even taken off the Crate for installation, the ECU was sent to BC in Canada, it's run good, but the Turbo pulses at Idle, it stops once it's in drive. How Can I copy the file from the ECU? I dont have any software to talk to it.
replyreply
09-14-2021, (Subject: 2009 ISX600...engine light-stop engine light ) 
Post: #6
RE: 2009 ISX600...engine light-stop engine light
(09-14-2021 )DavidG Wrote:  ...
Yes, the entire system was removed before it was even taken off the Crate for installation, the ECU was sent to BC in Canada, it's run good, but the Turbo pulses at Idle, it stops once it's in drive. How Can I copy the file from the ECU? I dont have any software to talk to it.

you need a laptop and a datalink adapter.. the software is easy to get. Many people usually just get it free off the interwebs in dark places .. unless you just want to be a goodie-2-shoes about it and buy it from the red engine maker for gowd-knows-what amount of fees.

doing a search for "Inline 6 adapter kit" off e-bay is where a lot of people get them... straight from china. They works just fine.


User's Signature: ->: What I post is just my own thoughts and Opinions! --- I AM Full Of S__T!.
replyreply




NOTE: Rawze.com is not affiliated, nor endorses any of the google ads that are displayed on this website.
  
  
Theme by MyBB Addict
Contact Us | Rawze.com | Return to Top | Return to Content | Lite (Archive) Mode | RSS Syndication