Isx15 cm2350 Low Power no codes
06-02-2022, (Subject: Isx15 cm2350 Low Power no codes ) 
Post: #1
Isx15 cm2350 Low Power no codes
2013 isx15 cm2350 demandated est 40k ago by running rough 735,000 Od overhauled at 490k truck has seemed to have intermittent power loss for a couple of months nothing crazy but last load the truck fought hard to get a 78k gross to speed on a flat hill no codes but it’s obvious now something is wrong. A couple of months ago I got one count of injector solenoid Driver cylinder 3 but truck was running fine than and code was inactive immediately after so I erased and no codes since. I pulled the valve cover and checked the injector harness no visible issues and I cleaned my imap and found an issue with my Air compressor leaking oil into the air intake so I’ve removed the compressor intake from the air intake and put a filter on it temporarily I’ll fix the compressor soon but to see if the truck would run better and cleaned all my tubing and it’s still running weak if I idle for 30 min maybe once or twice it’ll have a slight miss to it. I’m not sure what else I can besides but a over priced injector and hope that works and than continue to throw expansive parts at it. Also I just got new drive tires and a new Motive ELD device installed the Same day it started losing power oddly enough
replyreply
06-03-2022, (Subject: Isx15 cm2350 Low Power no codes ) 
Post: #2
RE: Isx15 cm2350 Low Power no codes
what is your boost and egt's doing when acting up?


and does it p[ass a rail leak-down test?...

http://rawze.com/forums/showthread.php?t...2#pid69262

... also, injector fault codes are not normal at all.. you need to replace the offending injector.


User's Signature: ->: What I post is just my own thoughts and Opinions! --- I AM Full Of S__T!.
replyreply
 Thanks given by: GhostHauling
06-03-2022, (Subject: Isx15 cm2350 Low Power no codes ) 
Post: #3
RE: Isx15 cm2350 Low Power no codes
One of my trucks started throwing random fault codes.. 1 for the injectors. 1 for def tank heater. 1 for low water. Stuff like that. Truck started coughing and running rough. I had him pull the motive plug off so I could plug in my Cummins fault reader and as soon as he unplugged it the engine perked up and 3 hours later the codes cleared.

May not fix your problem, but when I saw you just got a new eld, it reminded me on one of my problems.

Good luck


User's Signature: I'm not arguing.... I just wanna know why
replyreply
 Thanks given by: Rawze , GhostHauling




NOTE: Rawze.com is not affiliated, nor endorses any of the google ads that are displayed on this website.
  
  
Theme by MyBB Addict
Contact Us | Rawze.com | Return to Top | Return to Content | Lite (Archive) Mode | RSS Syndication